Installer: wrong version?

Feb 26, 2011 at 1:31 PM

I just downloaded the package from the Downloads page. I ran the .MSI installer and referenced the dll from my project. Weird enough the method Move() was not there, so I checked and saw that MultiTouch.Behaviors.WP7.dll is version 0.5.1.809 (instead of the expected 0.6.2). The .msi in the 0.6.1 package seem to be exactly the same file.

I tried to build the source but got some confusing result (the MultiTouch.Behaviors.Silverlight.WP7 gives PARSE_ERRORS), but I suppose it's not needed to build from source.

What am I doing wrong?

Feb 27, 2011 at 1:40 AM

Hi frenk,

this is correct.

Actually there are two different versions of the Behavior: 0.5.1 available in the installer and 0.6.2 available in the sample with source code.

Currently version 0.5.1 is available only for backward compatibility, the current version (0.6.2) uses a different codebase and adds many improvements like inertia, multiple elements and multi page support.

At this time there is no installer for v0.6.2.

Thanks,

Davide